Configuration wizard


This online tool generates for you the dependencies section of Gradle or Maven configuration files. Choose your project profile and copy/paste the generated result into your project dependency manager.

What type of Keyple component are you working on?


Application

  • Which card extension do you want to use?

  • Which reader plugin do you want to use?

  • In case of a distributed system, on which side is your application located?

  • Do you need additional services?


Reader plugin add-on

// Begin Keyple configuration (generated by 'https://keyple.org/components/overview/configuration-wizard/')
implementation("org.eclipse.keyple:keyple-common-java-api:2.0.1")
implementation("org.eclipse.keyple:keyple-plugin-java-api:2.3.1")
implementation("org.eclipse.keyple:keyple-util-java-lib:2.4.0")
// End Keyple configuration
// Begin Keyple configuration (generated by 'https://keyple.org/components/overview/configuration-wizard/')
implementation 'org.eclipse.keyple:keyple-common-java-api:2.0.1'
implementation 'org.eclipse.keyple:keyple-plugin-java-api:2.3.1'
implementation 'org.eclipse.keyple:keyple-util-java-lib:2.4.0'
// End Keyple configuration
<!-- Begin Keyple configuration (generated by 'https://keyple.org/components/overview/configuration-wizard/') -->
<dependency>
  <groupId>org.eclipse.keyple</groupId>
  <artifactId>keyple-common-java-api</artifactId>
  <version>2.0.1</version>
</dependency>
<dependency>
  <groupId>org.eclipse.keyple</groupId>
  <artifactId>keyple-plugin-java-api</artifactId>
  <version>2.3.1</version>
</dependency>
<dependency>
  <groupId>org.eclipse.keyple</groupId>
  <artifactId>keyple-util-java-lib</artifactId>
  <version>2.4.0</version>
</dependency>
<!-- End Keyple configuration -->

Card extension add-on

  • Do you need additional services?

Distributed solution add-on

  • For the “Local Service” component:

    // Begin Keyple configuration (generated by 'https://keyple.org/components/overview/configuration-wizard/')
    implementation("org.eclipse.keyple:keyple-common-java-api:2.0.1")
    implementation("org.eclipse.keyple:keyple-distributed-local-java-api:2.1.1")
    implementation("org.eclipse.keyple:keyple-util-java-lib:2.4.0")
    // End Keyple configuration
    // Begin Keyple configuration (generated by 'https://keyple.org/components/overview/configuration-wizard/')
    implementation 'org.eclipse.keyple:keyple-common-java-api:2.0.1'
    implementation 'org.eclipse.keyple:keyple-distributed-local-java-api:2.1.1'
    implementation 'org.eclipse.keyple:keyple-util-java-lib:2.4.0'
    // End Keyple configuration
    <!-- Begin Keyple configuration (generated by 'https://keyple.org/components/overview/configuration-wizard/') -->
    <dependency>
      <groupId>org.eclipse.keyple</groupId>
      <artifactId>keyple-common-java-api</artifactId>
      <version>2.0.1</version>
    </dependency>
    <dependency>
      <groupId>org.eclipse.keyple</groupId>
      <artifactId>keyple-distributed-local-java-api</artifactId>
      <version>2.1.1</version>
    </dependency>
    <dependency>
      <groupId>org.eclipse.keyple</groupId>
      <artifactId>keyple-util-java-lib</artifactId>
      <version>2.4.0</version>
    </dependency>
    <!-- End Keyple configuration -->

  • For the “Remote Plugin” component:

    // Begin Keyple configuration (generated by 'https://keyple.org/components/overview/configuration-wizard/')
    implementation("org.eclipse.keyple:keyple-common-java-api:2.0.1")
    implementation("org.eclipse.keyple:keyple-distributed-remote-java-api:3.0.1")
    implementation("org.eclipse.keyple:keyple-util-java-lib:2.4.0")
    // End Keyple configuration
    // Begin Keyple configuration (generated by 'https://keyple.org/components/overview/configuration-wizard/')
    implementation 'org.eclipse.keyple:keyple-common-java-api:2.0.1'
    implementation 'org.eclipse.keyple:keyple-distributed-remote-java-api:3.0.1'
    implementation 'org.eclipse.keyple:keyple-util-java-lib:2.4.0'
    // End Keyple configuration
    <!-- Begin Keyple configuration (generated by 'https://keyple.org/components/overview/configuration-wizard/') -->
    <dependency>
      <groupId>org.eclipse.keyple</groupId>
      <artifactId>keyple-common-java-api</artifactId>
      <version>2.0.1</version>
    </dependency>
    <dependency>
      <groupId>org.eclipse.keyple</groupId>
      <artifactId>keyple-distributed-remote-java-api</artifactId>
      <version>3.0.1</version>
    </dependency>
    <dependency>
      <groupId>org.eclipse.keyple</groupId>
      <artifactId>keyple-util-java-lib</artifactId>
      <version>2.4.0</version>
    </dependency>
    <!-- End Keyple configuration -->


<dependency>
  <groupId>org.eclipse.keyple</groupId>
  <artifactId>keyple-common-java-api</artifactId>
  <version>2.0.1</version>
</dependency>
<dependency>
  <groupId>org.eclipse.keyple</groupId>
  <artifactId>keyple-service-java-lib</artifactId>
  <version>3.2.2</version>
</dependency>
<dependency>
  <groupId>org.eclipse.keyple</groupId>
  <artifactId>keyple-service-resource-java-lib</artifactId>
  <version>3.0.1</version>
</dependency>
<dependency>
  <groupId>org.eclipse.keyple</groupId>
  <artifactId>keyple-util-java-lib</artifactId>
  <version>2.4.0</version>
</dependency>
<dependency>
  <groupId>org.eclipse.keyple</groupId>
  <artifactId>keyple-card-calypso-java-lib</artifactId>
  <version>3.1.1</version>
</dependency>
<dependency>
  <groupId>org.eclipse.keyple</groupId>
  <artifactId>keyple-card-calypso-crypto-legacysam-java-lib</artifactId>
  <version>0.7.0</version>
</dependency>
<dependency>
  <groupId>org.eclipse.keyple</groupId>
  <artifactId>keyple-card-calypso-crypto-pki-java-lib</artifactId>
  <version>0.2.0</version>
</dependency>
<dependency>
  <groupId>org.eclipse.keyple</groupId>
  <artifactId>keyple-card-generic-java-lib</artifactId>
  <version>3.0.1</version>
</dependency>
<dependency>
  <groupId>org.eclipse.keyple</groupId>
  <artifactId>keyple-distributed-local-java-lib</artifactId>
  <version>2.3.1</version>
</dependency>
<dependency>
  <groupId>org.eclipse.keyple</groupId>
  <artifactId>keyple-distributed-network-java-lib</artifactId>
  <version>2.4.0</version>
</dependency>
<dependency>
  <groupId>org.eclipse.keyple</groupId>
  <artifactId>keyple-distributed-remote-java-lib</artifactId>
  <version>2.4.0</version>
</dependency>
<dependency>
  <groupId>org.eclipse.keyple</groupId>
  <artifactId>keyple-plugin-android-nfc-java-lib</artifactId>
  <version>2.2.0</version>
</dependency>
<dependency>
  <groupId>org.eclipse.keyple</groupId>
  <artifactId>keyple-plugin-android-omapi-java-lib</artifactId>
  <version>2.1.0</version>
</dependency>
<dependency>
  <groupId>org.eclipse.keyple</groupId>
  <artifactId>keyple-plugin-cardresource-java-lib</artifactId>
  <version>2.0.1</version>
</dependency>
<dependency>
  <groupId>org.eclipse.keyple</groupId>
  <artifactId>keyple-plugin-pcsc-java-lib</artifactId>
  <version>2.2.1</version>
</dependency>
<dependency>
  <groupId>org.eclipse.keyple</groupId>
  <artifactId>keyple-plugin-stub-java-lib</artifactId>
  <version>2.2.1</version>
</dependency>
<dependency>
  <groupId>org.eclipse.keypop</groupId>
  <artifactId>keypop-reader-java-api</artifactId>
  <version>2.0.1</version>
</dependency>
<dependency>
  <groupId>org.eclipse.keypop</groupId>
  <artifactId>keypop-card-java-api</artifactId>
  <version>2.0.1</version>
</dependency>
<dependency>
  <groupId>org.eclipse.keypop</groupId>
  <artifactId>keypop-calypso-card-java-api</artifactId>
  <version>2.1.0</version>
</dependency>
<dependency>
  <groupId>org.eclipse.keypop</groupId>
  <artifactId>keypop-calypso-crypto-legacysam-java-api</artifactId>
  <version>0.6.0</version>
</dependency>

Previous
Next